Recent Changes · Search:

Support the Project

Wikipublisher

PmWiki

edit SideBar

Wikipublisher.InstallTheServer-OSX History

Hide minor edits - Show changes to output

07 May 2014 at 09:07 AM by John Rankin - update to cover OS X v10.9
Changed lines 11-12 from:
These are on the OS X installation DVD, under ''Optional Installs''.
to:
These are on the OS X installation DVD, under ''Optional Installs''. Newer operating system versions require installation of the Xcode app plus the command line tools from the Apple app store.
Added lines 20-23:

sudo port install p5-perlmagick

The older instruction no longer works:
21 November 2010 at 10:10 AM by cd - Added step to untar Wikipublisher. I couldn't find mkprf.pl at this point
Changed line 37 from:
We have to use the version of Perl that `MacPorts installed, not the one that ships with Mac OS X. Change the first line of mkpdf.pl to read:
to:
We have to use the version of Perl that `MacPorts installed, not the one that ships with Mac OS X. After untarring Wikipublisher server, change the first line of mkpdf.pl to read:
27 December 2008 at 08:48 PM by John Rankin - add optional latexrender patch
Changed lines 1-2 from:
The following instructions worked for Mac OS X 10.5.2, client version. It should ensure all the requirements for running the Wikibook Server are satisfied.
to:
The following instructions worked for Mac OS X 10.5.2 and above, client version. It should ensure all the requirements for running the Wikibook Server are satisfied.
Changed lines 43-44 from:
Now continue with the InstallTheServer process.
to:
If you Cookbook/ActivateLatexrender, you also have to make sure the "convert" utility can find {gs|ghostscript}. From the Terminal, enter the following at the command line prompt (makes a symlink to the gs binary):

sudo ln -s /usr/local/bin/gs /usr/bin/gs

Now continue with the InstallTheServer process.
12 March 2008 at 01:16 PM by John Rankin - Preparing Mac OS X
Added lines 1-44:
The following instructions worked for Mac OS X 10.5.2, client version. It should ensure all the requirements for running the Wikibook Server are satisfied.

(:title Install the Server-OS X:)

!!!Install LaTeX and friends

Download and install [[The MacTeX Distribution -> http://www.tug.org/mactex/]].

!!!Install the Xcode Tools

These are on the OS X installation DVD, under ''Optional Installs''.

!!!Install `MacPorts

Follow the instructions for [[Installing MacPorts -> http://www.macports.org/install.php]].

!!!Install `ImageMagick with Perl

Open the Terminal application and enter the following at the command line prompt:

sudo port install `ImageMagick +perl

!!!Install the Perl LWP::`UserAgent

From the Terminal, enter the following at the command line prompt:

sudo perl -MCPAN -e shell;

This will start a Perl session and present a number of prompts. Reply "no" to the first prompt and "yes" to the rest. Then enter the following command at the CPAN console prompt:

install LWP::`UserAgent

When it has finished (it will ask a number of questions), enter "q" to return to the Terminal.

!!!Set the Perl path in mkpdf.pl

We have to use the version of Perl that `MacPorts installed, not the one that ships with Mac OS X. Change the first line of mkpdf.pl to read:

#!/opt/local/bin/perl

!!!Configure the paths

Now continue with the InstallTheServer process.
Creative Commons License
Edit · History · Print · Recent Changes · Search · Links
Page last modified on 07 May 2014 at 09:07 AM