Recent Changes · Search:

Support the Project

Wikipublisher

PmWiki

edit SideBar

Wikipublisher.UpgradingToPmWiki22 History

Hide minor edits - Show changes to output

01 May 2009 at 01:42 PM by John Rankin - patch for pagelist no longer required
Changed lines 28-30 from:
# if you wish to `PDF pages containing pagelist directives, you need to modify scripts/pagelist.php so that Wikipublisher can over-ride the default `MarkupToHTML function when generating Wikibook `XML:
to:
# if you are running PmWiki 2.2.1 or above and Wikipublisher 2.2.10 or above, you are done

# if you are running earlier versions and
wish to `PDF pages containing pagelist directives, you need to modify scripts/pagelist.php so that Wikipublisher can over-ride the default `MarkupToHTML function when generating Wikibook `XML:
Changed line 68 from:
This appears to be a mis-feature of the PmWiki scripts/transition.php script, which turns on ''all'' transition flags if ''any'' such flags are enabled. Wikipublisher enables the fplbygroup transition.
to:
This appears to be a mis-feature of the PmWiki scripts/transition.php script, which turns on ''all'' transition flags if ''any'' such flags are enabled. This was fixed in PmWiki 2.2.0-beta66. Wikipublisher enables the fplbygroup transition.
30 June 2008 at 10:37 AM by John Rankin - add transition notes
Added lines 5-6:
(:toc:)
Added lines 50-66:

!!!Transition issues

Some users may encounter problems arising from how PmWiki handles transition from older, now-deprecated markup rules. After installing Wikipublisher, some markup rules or third party recipes may seem to behave in unexpected ways; for example:
* nested divs
* custom edit screens
* vertical space
* wiki words
* start of line spaces

If so, try adding the following line at the end of local/config.php:

[@
SDV($Transition['version'], 2001999);

@]
This appears to be a mis-feature of the PmWiki scripts/transition.php script, which turns on ''all'' transition flags if ''any'' such flags are enabled. Wikipublisher enables the fplbygroup transition.
20 June 2008 at 12:51 PM by John Rankin - change 2.1.11 to 2.2.x
Changed lines 1-2 from:
This page provides instructions for upgrading from PmWiki 2.1.27 and [[Wikipublisher]] 2.1.10 or below to PmWiki 2,2.x and Wikipublisher 2.1.11 or above. There is also a special note for those running the [[InstallTheServer |Wikibook server]] software. The instructions assume you are running PmWiki 2.1.27 and refer to Wikipublisher version 2.1.11, which works with PmWiki 2.1.27 and 2.2beta65 or above.
to:
This page provides instructions for upgrading from PmWiki 2.1.27 and [[Wikipublisher]] 2.1.10 or below to PmWiki 2.2.x and Wikipublisher 2.1.11 or 2.2.x. There is also a special note for those running the [[InstallTheServer |Wikibook server]] software. The instructions assume you are running PmWiki 2.1.27 and refer to Wikipublisher version 2.1.11 or 2.2.x, which work with PmWiki 2.1.27 and 2.2beta65 or above.
Changed lines 5-6 from:
!!!Install and test Wikipublisher 2.1.11 under 2.1.27
to:
!!!Install and test Wikipublisher 2.2.x under 2.1.27
Changed line 11 from:
# download Wikipublisher version 2.1.11 from the Cookbook:PublishPDF page
to:
# download Wikipublisher version 2.2.x from the Cookbook:PublishPDF page
30 January 2008 at 02:51 PM by John Rankin - describe upgrade process
Added lines 2-3:

(:title Upgrading to PmWiki 2.2:)
30 January 2008 at 02:49 PM by John Rankin - describe upgrade process
Added lines 1-51:
This page provides instructions for upgrading from PmWiki 2.1.27 and [[Wikipublisher]] 2.1.10 or below to PmWiki 2,2.x and Wikipublisher 2.1.11 or above. There is also a special note for those running the [[InstallTheServer |Wikibook server]] software. The instructions assume you are running PmWiki 2.1.27 and refer to Wikipublisher version 2.1.11, which works with PmWiki 2.1.27 and 2.2beta65 or above.

!!!Install and test Wikipublisher 2.1.11 under 2.1.27

# back up your wiki installation, so you can revert to a known state if necessary

# run a small selection of `PDF tests (say 3 representative pages)

# download Wikipublisher version 2.1.11 from the Cookbook:PublishPDF page

# read the README file and install the cookbook/wikipublisher scripts and pub/ components

# test that the previously-generated `PDF files still generate correctly


!!!Install and test PmWiki 2.2.x

# back up your wiki installation, so you can revert to a known state if necessary

# follow the normal PmWiki upgrade process

# test that the previously-generated `PDF files still generate correctly

# if you wish to `PDF pages containing pagelist directives, you need to modify scripts/pagelist.php so that Wikipublisher can over-ride the default `MarkupToHTML function when generating Wikibook `XML:
** look for the function `FPLTemplate( ... )
** immediately after the global statement, add [@global $FPLMarkupFunction;@] and [@SDV($FPLMarkupFunction, 'MarkupToHTML');@]
** near the end of the `FPLTemplate function, change [@MarkupToHTML( ... )@] to [@$FPLMarkupFunction( ... )@]

!!!Why we need to modify pagelist.php

# Wikipublisher teaches PmWiki how to convert wiki markup into Wikibook `XML instead of `XHTML

# it starts off by qualifying all Wikibook `XML tags with a namespace prefix

# at the end of the wiki markup to `XML conversion process, it removes all tags that don't have a namespace qualifier, on the assumption that they are probably residual `XHTML tags that were not converted to Wikibook

# it then removes the namespace qualifier, leaving pure Wikibook `XML

# but pagelist.php calls `MarkupToHTML (the inner call) and this is inside another call to `MarkupToHTML (the outer call)

# at the end of the inner call, all the Wikibook tags have had their namespace qualifiers stripped away, so the outer call thinks they are `XHTML and removes them

# the fix is to substitute a function for the inner call that first calls `MarkupToHTML and then ''puts back the namespace qualifiers''

# now the outer call finds correctly-qualified Wikibook `XML tags and leaves them alone

!!!Important information for Wikibook server users

If you are running your own Wikibook server, as described in InstallTheServer, when you upgrade to PmWiki 2.2.x you also need to update local/`AccessControl.SplashScreen.php. An update is included in Attach:accesscontrol.tar.gz.

This update fixes a problem that prevents sites running PmWiki 2.2.x from displaying the server version number when the Wikibook server displays the AccessControl/SplashScreen.
Creative Commons License
Edit · History · Print · Recent Changes · Search · Links
Page last modified on 01 May 2009 at 01:42 PM